As of: 2015-04-21

Yes!


PFixer version v1.6.1 and later work out of the box with Lightroom Classic CC v7. 


Have at it!


LR Classic CC v7 will install alongside previous versions, so if you ever need to revert to your previous LR version, you are free to do so.